Highslide for Wordpress Plugin

將報錯的語句做如下修改(例):

foreach($extcredits as $id => $credit)
{
         if($credit[‘ratio’]) 
         {
                 $exchcredits[$id] = $credit;
         }
}

改為

if(is_array($extcredits))    //add
{

         foreach($extcredits as $id => $credit) 
         {
                  if($credit[‘ratio’]) 
                  {
                              $exchcredits[$id] = $credit;
                  }         
        }
}   //add

foreach((array)$extcredits as $id => $credit)
{
         if($credit[‘ratio’]) 
         {
                 $exchcredits[$id] = $credit;
         }
}

造成這個錯誤的原因多數是因為論壇升級、編碼轉換造成的!
如果對PHP熟悉的人,可以直接找到出錯的地方,分析出錯信息是對哪個數據庫表操作時造成的,然後,找到相應表的原版數據導進去,問題可解決。
如果對PHP不熟悉的人,可以按出錯信息提示的位置,用上述修改方法進行修改,問題可解決。

Related Posts with Thumbnails
留下迴響